New Experience realms not working on secondary servers

Follow
    Applies to:
  • SecureAuth Identity Platform
Deployment model:
  • Hybrid
  • Version Affected:  23.07 and potentially 24.04

    Description:  

    New Experience realms do not working on secondary servers in 23.07 due to an issue with the password replication from the Primary to the Secondary server

     

    Cause:  

    When Filesync syncs the password from the Primary SecureStore to the secondary, the secondary incorrectly locks itself out from the store and throws a 500 error

     

    Resolution:  

    1. Disable Filesync replication of the SecureStore by following these steps.

    i. On the Primary, navigate to D:\MFCApp_Bin\Appliance_Sync\FileSyncService

    ii. Back up idpservices.list

    iii. Replace it with the attached idpservices.list  (It's at the very bottom of this article)

    iv. Navigate to D:\SecureAuth\SecureAuth0 and replace the idpservices.list with the attached version.

    v. Delete the syncmanifest.xml file from D:\SecureAuth\SecureAuth0

    vi. Restart filesync on the primary.

    2. On the Secondary, stop the SecureStorageApiAppPool application pool

    3. Manually move the SecureStore on the secondary from 

    D:\SecureAuth\SecureStorageApi\SecureAuth Corporation\SecureStore\Replication\Inbound to 

    D:\SecureAuth\SecureStorageApi\SecureAuth Corporation\SecureStore\Replication\Outbound

    (ensure you remove it from inbound)

    4. On the Secondary, start the SecureStorageApiAppPool application pool

     

    Special Considerations :  

    This should be resolved by Hotfix 8 as soon as it's available.

     

     

    SecureAuth Knowledge Base Articles provide information based on specific use cases and may not apply to all appliances or configurations. Be advised that these instructions could cause harm to the environment if not followed correctly or if they do not apply to the current use case.

    Customers are responsible for their own due diligence prior to utilizing this information and agree that SecureAuth is not liable for any issues caused by misconfiguration directly or indirectly related to SecureAuth products.

    0 out of 0 found this helpful

    Comments

    0 comments

    Please sign in to leave a comment.